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Utilizing Notes in iConnect 
 

Introduction 

Notes in iConnect are a way for Providers, Waiver Support Coordinators (WSCs) 
and APD staff to communicate and share information while keeping records in 
either the Provider Record or the Consumer Record. Depending on the workflow, 
there are specific Note Types, Note Sub-Types, Descriptions, Status, Attachments 
and Recipients required. 

 
This job aid will encompass the basic skills in using the Note function in iConnect. 
It is important to visit the appropriate Chapters or Job Aids for the specific tasks 
and workflows to ensure you use the appropriate responses in the fields. 

 
Objective of this job aid: to understand the importance of using Notes in 
iConnect and the importance of utilizing the appropriate response in the 
corresponding field options. 

 
Specific Workflows that use Notes in iConnect: 
Behavior 
Employment Services - IFS  
Expansion Requests 
Home Health Care Services (HHCS) 
ICF Transitions 
Life Skills Development  
Quality Assurance  
Reactive Strategies  
Residential Habilitation  
Residential Planning 
Supply, Equipment, Adaptation, Emergency Response System and Dental 
Supported Living 
Support Plan 
Therapeutic and Residential Nursing 
Waiver Support Coordination (WSC) 

https://apd.myflorida.com/waiver/iconnect/behaviorlib.htm
https://apd.myflorida.com/waiver/iconnect/docs/APD%20iConnect%20Employment%20Services%20Training%20Guide%20v6_FINAL%20050423NE.pdf
https://apd.myflorida.com/waiver/iconnect/providers.htm
https://apd.myflorida.com/waiver/iconnect/hhcslib.htm
https://apd.myflorida.com/waiver/iconnect/docs/iConnect_ICF_TrainingGuide%20V3d_050923.pdf
https://apd.myflorida.com/waiver/iconnect/lsdlib.htm
https://apd.myflorida.com/waiver/iconnect/qalib.htm
https://www.youtube.com/watch?v=8lnOrxOJboQ
https://apd.myflorida.com/waiver/iconnect/reshablib.htm
https://apd.myflorida.com/waiver/iconnect/docs/iConnect_ResidentialPlanning_TrainingGuideV3%20050923NE.pdf
https://apd.myflorida.com/waiver/iconnect/supply-equipment-adaptation-emergency-dental.htm
https://apd.myflorida.com/waiver/iconnect/supportedlivinglib.htm
https://apd.myflorida.com/waiver/iconnect/therapeutic.htm
https://apd.myflorida.com/waiver/iconnect/wsc.htm
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Note Locations in iConnect – Provider Record 

Your Role in iConnect will determine your access. 

• The Service Provider Role will have access to both the Provider Notes and 
Consumer Notes. 

• WSCs, Service Provider Workers and Provider EVV Managers will only have 
access to the Consumer’s Notes. 

 
1. To begin, log into iConnect and set Role = Service Provider. Click Go. When you 

land on My Dashboard, you will see columns labeled CONSUMERS and 
PROVIDERS. Under those corresponding columns are Notes. Notes under the 
CONSUMERS heading are Notes that were created on the Consumer Record and 
are part of that consumer’s central record. Notes under the Provider Record are 
notes that were created in the Provider Record and are part of the Provider’s 
record. If you do not see the heading labeled Notes, that indicates that you do not 
have any Unread Notes. 

 
a. It is important to remember that consumer case management related 

notes should not be included within the provider record and vice 
versa. Follow the appropriate workflows for plans of remediation and 
corrective action plans. 
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2. To view either Complete Notes or Pending Notes, click the corresponding 
hyperlink. 

 
 

3. Click the hyperlink of the Note you want to read. The Note will show once 
selected. 

 

 

 
PRO TIP: Utilizing the filters can assist the user in finding Notes faster. 
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4. To remove the Note from your My Dashboard, navigate to Tools > Mark as Read 
and Close. 

 

To locate any Note from your Provider Record marked as Read, navigate to your 
Provider Record > Notes tab to view any previously Read Notes. 
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Note Locations in iConnect – Consumer Record 

Your Role in iConnect will determine your access. Service Provider, WSC, Service 
Provider Worker and Provider EVV Manager will have access to the Consumer’s 
Notes. 

 
1. To begin, log into iConnect and set Role = Service Provider, Service Provider 

Worker, or WSC. Click Go. When you land on My Dashboard, you will see a 
column labeled CONSUMERS. Notes under the CONSUMERS heading are Notes 
that were created on the Consumer Record and are part of that consumer’s central 
record. If you do not see the heading labeled Notes, that indicates that you do not 
have any Unread Notes. 

 
a. It is important to remember that consumer case management related 

notes should not be included within the provider record and vice 
versa. Follow the appropriate workflows for plans of remediation and 
corrective action plans. 
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2. To view either Complete Notes or Pending Notes, click the corresponding 
hyperlink. 

 
3. Click the hyperlink of the Note you want to read. Once selected, your note will 

appear. 
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PRO TIP: Utilizing the filters can assist the user in finding Notes faster.  
 

4. To remove the Note from your My Dashboard, navigate to Tools > Mark as Read 
and Close. If you mark a Support Plan or Support Plan Provider Copy Note as Read, 
you will no longer have access to that Note, therefore make sure to download that 
document prior to marking it as read OR leave it as unread for future access. 

 

 
To locate a Note from the Consumer Record marked as Read, navigate to the 

Consumer Record > Notes tab to view any previously Read Notes. This will NOT work 
with Support Plan or Support Plan Provider Copy Note Types. 
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NEW: Note Locations in iConnect – Consumer Record – Support Plan Note 

WSCs have 30 days from the effective date of the Person Center Support Plan 
(PCSP) to send the PCSP to the appropriate providers. The WSCs will send the 
PCSP in a Note in iConnect within the Consumer’s record. WSCs will utilize the 
WSC Advisory 2021-040 Person Centered Support Plan Updates to assist in 
developing the Note.  
 

1. Providers will monitor their My Dashboard to view any Pending or Complete 
Notes.  

 
 

2. Click either Pending or Complete to view the list view grid and select the Note 
Type = Support Plan and Note Sub Type = Provider Copy 

 
 

3. View the Note and Attachment. The attachment is able to be downloaded.  
 

 
REMINDER: Personal Health Information (PHI) will be included when downloading 
the PCSP. It is the responsibility of all iConnect users to ensure that their systems 

follow all HIPAA requirements. 
 

https://apd.myflorida.com/waiver/docs/WSC%20Advisory%202021-040%20Person%20Centered%20Support%20Plan%20Updates.pdf
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4. The Note will then be closed out. No additional updates should be made to the 
Note. Do not change the status of the Note.  
 

a. If the PCSP is downloaded, the user will be able to go to Tools > Mark 
as Read and Close 

 
REMINDER: Providers are not required to mark these notes as Read, if they 
choose to access the PCSP directly from the note as needed.  

 

 
 

REMINDER: If the Support Plan note is marked as Read, the provider will no 
longer have access to that Note.  

 
b. If the PCSP is NOT downloaded, the user will be able to go to File > 

Close Notes 

 
Creating a Note in iConnect 

Notes are a way for service providers and WSCs to communicate with APD staff 
and each other through iConnect. It is crucial that if a Note is needed to be read by 
an individual that they are added as a Note Recipient. A Note without a Note 
Recipient is similar to an email in the Drafts folder, no one knows it is there. When 
creating Notes, it is imperative to follow the proper workflow to ensure that each 
step is followed. Utilizing the incorrect Note Type or Note Sub-Type could cause 
issues for the recipient, which could potentially jeopardize services for our 
consumers. Utilize the links provided earlier to ensure that you follow the 
appropriate workflow. 
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NEW: Uploading Attachments and Adding Note Recipients  

There are times in which a user needs to upload a document in iConnect. This is 
done in the Notes tab of either the Consumer’s record or the Provider’s record, 
depending on the documentation being uploaded.  The user may need to update the 
name of a file with iConnect as well when attaching the document. 
 

1. Navigate to the Notes tab of the appropriate record (Consumer’s record or 
Provider’s record).  

 

2. Go to File > Add Notes 

 

3. Fill out the fields as it pertains to the corresponding workflow.  

 



Utilizing the Note Tab in the Provider &  
Consumer Records 

December 20, 2024 Page 11 

 

 

 
4. If an attachment is needed, click Add Attachment 

 
 

5. A pop-up will display. Click Choose File 

 
6. Select the appropriate file and click Open. 

 
 

7. PRO TIP: The user can create a new name for the attachment to make the 
attachment easier to identify.    

a. Click the create new radio button  
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b. Type in the new name along with the extension of the file. The extension 
should match the original extension.  

 
c. Add a description if needed. 

                 
 

d. Click Upload 

 
PRO TIP: If there are multiple attachments needed in the same note, choose 
Upload and Add Another  

 
8. Add needed Note Recipients as indicated in the appropriate workflows.  

a. Click the Lookup button 
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b. Type in the name of the Note Recipient and click Search. Click the 
correct Note Recipient.  

 
 

PRO TIP: Utilize the Ctrl + F keyboard short cut can assist in the search if the 
Last Name yields several results. Utilizing the keyboard click Ctrl + F and type in 
the first name of the recipient. It will highlight the name(s) in the results.   

 
  

9. Go to File > Save and Close Notes 
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Best Practices with Notes in iConnect 

There are some best practices to help ensure that all iConnect users are successful 
with iConnect. 

1. Apart from the Support Plan Provider Copy Note and the Support Plan Notes (for 
Providers of Non-WSC services), it is best practice for ALL providers to mark 
Notes as Read to clear your My Dashboard. 

a. Notes can also be marked as read from the list view of your Notes from 
your My Dashboard. 

i. Once logged into iConnect, select your appropriate Role and 
press Go.  

 
ii. On your My Dashboard, you will click the Notes you want to 
view (Providers/Consumers and Pending or Complete).

 
iii. From the list grid view, you can check mark all or a few of the Notes 

from the right-hand side. Then navigate to Tools > Mark as Read. 
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b. Notes can also be marked as read from the opened Note. 

i. Once logged into iConnect, select your appropriate Role and press 
Go. On your My Dashboard, you will click the Notes you want to 
view (Providers/Consumers and Pending or Complete). 

 
ii. Select the Note you want to view. 

 

 

iii. Then navigate to Tools > Mark as Read or Mark as Read and 
Close. 
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2. Ensure the correct Note Recipient. 
a. If you see that there are two individuals with the same name when 

searching for the worker as a Note Recipient, reach out to the individual 
and inquire into the Member ID. 

 

b. To find your Member ID, the Service Provider (Owner) can go to their 
Provider Record > Workers and select the Worker’s name. The screen 
will show their Member ID for their agency. (Workers will have a different 
Member ID for each Agency they work for.) 

 
PRO TIP: The Service Provider (Owner) can edit the title for their employee in order to 
ensure that the worker can be easily identified as an employee for their organization. 
 

 
3. Verify if a Note Recipient has “Read” the Note to determine if they need to be 

added again. 

a. Navigate to the Note you want to verify. Then scroll down to see the Note 
Recipients. 
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b. If the Note is marked Unread, that means the Note is still on the recipient’s 

My Dashboard. If the Note is marked Read, that means the Note is no 
longer on the recipient’s My Dashboard. User will be able to resend the 
Note to that user if needed. 

i. Unread – The Note is on the recipient’s My Dashboard. 
ii. Read – The Note is no longer on the recipient’s My Dashboard.  
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Troubleshooting 
 

There are times when things do not go as planned. This section will help you to 
determine why there might be issues with the Notes in iConnect. 
 

1. Not getting a response to the Note I sent, or I was told I was added to a Note and I 
don’t see it. 
a. Incorrect Recipient- Check the name of the recipients and determine if the 

name was incorrect or if they have a different Member ID number. Reference 
Best Practices with Notes in iConnect Number 2. 

b. Verify that the correct Note Type and Note Sub-Type was used in the 
workflow. (Not all providers have access to the same Note Types and Note 
Sub-Types.) 

c. Verify the Note was done on the proper Record. For example: If a Provider 
sent a Note to a WSC from the Provider Record, the WSC would not have 
access to that Note, since it is not part of the Consumer Record. 
 

2. I am unable to respond to a Note or I was informed that a recipient was not able to 
respond to my Note that I sent. 

a. Check the Status of the Note. Notes in Complete status can no longer be 
edited. To change the Status of a Complete Note, a ticket request must be 
done. Not all Notes are allowed to be reversed and a New Note may need to 
be done. 

 

 



Utilizing the Note Tab in the Provider &  
Consumer Records 

December 20, 2024 Page 19 

 

 

b. If the Note is in Draft Status, only the creator can respond to the Note. The 
creator will need to follow the appropriate workflow and change the status of 
the Note. 

 
3. I am not able to Save the Note I am creating. 

a. If you are not able to Save due to the Division not populating, contact your 
Regional iConnect Trainer. 

 
 

b. If you are not able to Save due to the Program/Provider not showing your 
Agency, contact the WSC and asked to be added to the Provider Selection 
Tab of the Consumer’s Record. 
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